Incident

Impact: Major incident
Affected Region(s): EU-DE
Affected Service(s): Elastic Volume Service
Incident began at 2024-07-22T15:32:28.746570Z  and ended at 2024-07-22T18:07:17.344752Z 
resolved
2024-07-15T13:55:13.341104Z 
We found no issues regarding the service.

resolved
2024-07-15T13:55:13.341104Z 
We found no issues regarding the service.