Incident

Impact: Minor incident (i.e. performance impact)
Affected Region(s): EU-DE
Affected Service(s): Direct Connect, VPC Endpoint
Incident began at 2023-12-11T16:53:17.542530Z  and ended at 2023-12-11T21:43:43.933838Z 
resolved
2023-12-11T21:43:43.929803Z 
Minor issues due to the introduction of new Status Dashboard.

resolved
2023-12-11T21:43:39.143286Z 
Minor issues due to the introduction of new Status Dashboard.